iLearn Help and FAQ

ID #1017

What are the system requirements for iLearn?

In order to access Resources and Activities in your online unit, you will need a browser such as Firefox or Chrome. iLearn will operate on the following browsers, it is recommended that you upgrade your browser to the most recent version: